
Network instability (Telekom Italia)
Started 13 May at 11:28am GMT-3, last updated 14 May at 03:07pm GMT-3.
Updated
Our network team has received a response from Telekom Italia Brazil informing us that the issue has been resolved.
Resolved
Instability apparently resolved, we have not yet received a response from Telekom Italia. Waiting for further updates.

Updated
Our Network Team contacted Telekom Italia Brazil (TIM) seeking feedback on when the instability will be resolved. We reiterate that the instability is not from Square but rather from connections coming from Brazil. We also detected instabilities from Vivo (but no response so far).
Updated
Instability appears to be isolated to cases in LATAM, all checks in Europe, Asia and North America show no failures. Connections coming from Latin America, we detected instabilities via the Vivo and Tim Fiber network, we are looking for some status update to provide here.

Created
We have detected an instability in our network that affects all clusters, we are investigating the cause of the situation.