Get in touch
Back
Resolved

High Latency in Email Deliverability

Started 25 Mar at 09:25am GMT-3, resolved 25 Mar at 10:11am GMT-3.

Auth Billing
Resolved

We are pleased to report that the temporary disruption affecting transactional email delivery has been fully resolved.

Following a successful manual review by our external provider's compliance specialists, the preventive restriction has been lifted and the delivery queue has been cleared. All pending messages, including onboarding emails, payment confirmations, and infrastructure alerts, have been dispatched and should reach your inbox shortly.

We confirm that all Square Cloud hosting services and control panels remained 100% stable throughout this period. We appreciate the patience of our developer community while we worked to ensure a manual override of this false positive with our global delivery partner.

Monitoring: Our team will continue to monitor delivery performance over the next few hours to ensure optimal service.

Posted 25 Mar at 10:11am GMT-3.
Created

We have identified a temporary disruption affecting the delivery of transactional emails across our platform. This impact is specifically limited to onboarding messages, payment confirmations, and automated infrastructure alerts.

The root cause has been traced to an inconsistency within our external email provider's automated filters, leading to an unusual processing queue. Rest assured, our team is already in direct contact with the provider's compliance specialists to flush the queue and restore instant delivery.

Important Note: All Square Cloud hosting systems and your Control Panel remain 100% operational. Only automated email notifications are experiencing this temporary lag.

Posted 25 Mar at 09:25am GMT-3.